Connectivity Issues
Resolved
Oct 30 at 09:00am AWST
We’re pleased to confirm that WorQ services have been fully restored. Earlier today, customers in Australia experienced degraded performance and intermittent access due to an issue with Microsoft Azure Front Door (AFD).
Status
Current state: Operational – performance and availability have returned to normal.
Impact window: 3:00 AM to 12:00 PM on 30/10/2025.
Data & security: No customer data was lost or compromised.
What happened
Microsoft reported a fault affecting AFD edge traffic, which caused intermittent timeouts and slow responses for services routed through AFD.
What we did
Monitored the Microsoft incident and verified restoration as fixes were deployed.
Ran post-recovery checks across WorQ application, APIs, and authentication flows.
Cleared any stale edge caches and validated origin health.
Next steps
We’ll continue enhanced monitoring over the next 24 hours.
We’re reviewing our failover playbooks and DNS/edge routing options to further reduce risk from similar upstream incidents.
A brief post-incident summary will be shared within [timeframe] for transparency.
If you continue to see any anomalies, please raise a ticket with WorQ Support at support@worq.com.au, and include timestamps, URLs, and request IDs where possible.
Thank you for your patience today.
Affected services
Created
Oct 30 at 04:22am AWST
Due to an outage with Azure Front Door we are currently seeing high failure rates.
https://azure.status.microsoft/en-us/status
We are seeing some signs of recovery.
Affected services